Issue in Opencart Version 3.0.3.5 and 3.0.3.6 OCMOD Twig Error

Views:
 
Category: Others/ Misc
     
 

Presentation Description

All of the Purpletree opencart extensions use OCMOD modification for various operations. Opencart allows the use of OCMOD in extensions, using which we can modify core files of the opencart, and this is being approved method of Opencart. get this link:- https://bit.ly/329swpa

Comments

Presentation Transcript

Issue in Opencart Version 3.0.3.5 and 3.0.3.6 OCMOD Twig Error:

Issue in Opencart Version 3.0.3.5 and 3.0.3.6 OCMOD Twig Error

Slide2:

Purpletree Software LLP creates  Opencart Extensions  which admin can easily install from the admin panel. All our extensions are easy to use and once purchased admin can install it by following the user guide of that particular extension. No need to have any technical knowledge of coding if someone wants to use Purpletree Extension on their open cart website. During installation or later, if the customer faces any issue, our  Helpdesk  is always there to raise their complaints regarding the same, and that would be solved by a Team of professional Developers by Purpletree .  All of the Purpletree opencart extensions use OCMOD modification for various operations. Opencart allows the use of OCMOD in extensions, using which we can modify core files of the opencart , and this is being approved method of Opencart . But when we use Opencart latest versions 3.0.3.5 and 3.0.3.5, OCMOD is not able to modify core view twig files of opencart . This issue is only being faced by customers who have recently upgraded to Opencart v3.0.3.5 and v3.0.3.6. All the previous versions are bug-free, and all of the Purpletree extensions work properly on the previous version, so the latest version of opencart which is no issues is Opencart v3.0.3.3 as Opencart v3.0.3.4 is not being released by opencart or has been discarded.

Slide3:

Reference -  https://forum.opencart.com/viewtopic.php?f=199&t=219093#p793979 Reference Github Link -  https://github.com/opencart/opencart/blob/3.0.x.x_Maintenance/upload/system/modification.xml As suggested in reference follow the steps below as Replace the file root/upload/system/modification.xml with the above-fixed file.

Slide4:

Replace the file root/upload/system/modification.xml with the above-fixed file . Now Login to Admin Panel, then Extensions > Modifications > Refresh the modifications. If Unable to Access admin panel due to error, just delete your modification files in `/storage/modification/` or as a defined folder in Config File. These would be the cache files and would be created on runtime again . Now Clear the Cache from Admin Dashboard.

Slide5:

Improvements done by Opencart or anyone must be checked thoroughly with each new release, this is a major issue which is faced by mainly the Opencart Extension developers. We hope Opencart would officially solve this issue soon, until then use the said fix or use Stable versions of Opencart v3.0.3.3 or earlier.

authorStream Live Help