Βασικές εντολές

Views:
 
Category: Education
     
 

Presentation Description

structured programming in Greek

Comments

Presentation Transcript

Βασικές εντολές:

Βασικές εντολές Δομημένος προγραμματισμός

Τι είναι ιεραρχικός προγραμματισμός;:

Τι είναι ιεραρχικός προγραμματισμός; Είναι τεχνική σχεδίασης αλγορίθμου. Αρχικό πρόβλημα υποπρόβλημα1 υποπρόβλημα2 υποπρόβλημα3 Το αρχικό πρόβλημα διασπάται σε πολλά απλούστερα υποπροβλήματα Η επίλυση των υποπροβλημάτων οδηγεί στην επίλυση του αρχικού προβλήματος.

Τι είναι ιεραρχικός προγραμματισμός;:

Τι είναι ιεραρχικός προγραμματισμός; Ιεραρχικός προγραμματισμός καλείται η τεχνική σχεδίασης αλγορίθμου κατά την οποία το πρόβλημα διασπάται σε μια σειρά από απλούστερα προβλήματα , τα οποία όταν επιλυθούν , οδηγούν στην επίλυση του αρχικού προβλήματος .

Τι είναι τμηματικός προγραμματισμός;:

Τι είναι τμηματικός προγραμματισμός; Είναι τεχνική συγγραφής προγράμματος Ακολουθεί τις αρχές της ιεραρχικής σχεδίασης Αποτελείται από ανεξάρτητα λογικά τμήματα Τα ανεξάρτητα τμήματα είναι μικρά

Τι είναι δομημένος προγραμματισμός;:

Τι είναι δομημένος προγραμματισμός; Είναι μεθοδολογία συγγραφής προγράμματος Βασίζεται στην αρχή του « διαίρει και βασίλευε » (Διάσπαση προβλήματος σε υποπροβλήματα = ιεραρχική σχεδίαση + τμημ/κός προγρ/σμός ) Χρησιμοποιεί μόνο τις βασικές αλγοριθμικές δομές ( ακολουθία , επιλογή και επανάληψη )

Δομή ακολουθίας: Εντολές Εισόδου:

Δομή ακολουθίας: Εντολές Εισόδου ΔΙΑΒΑΣΕ Παραδείγματα

Δομή ακολουθίας: Εντολές εξόδου:

Δομή ακολουθίας: Εντολές εξόδου Παραδείγματα ΓΡΑΨΕ

Δομή ακολουθίας: Εντολή εκχώρησης:

Δομή ακολουθίας: Εντολή εκχώρησης  Παραδείγματα

Δομή επιλογής: Εντολές ελέγχου:

Δομή επιλογής: Εντολές ελέγχου ΑΝ… ΤΕΛΟΣ_ΑΝ Παραδείγματα

Δομή επανάληψης: Εντολές επανάληψης:

Δομή επανάληψης: Εντολές επανάληψης Παραδείγματα ΓΙΑ… ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

authorStream Live Help