FOR statement2

Views:
 
Category: Education
     
 

Presentation Description

programming

Comments

Presentation Transcript

ΔΟΜΗ ΕΠΑΝΑΛΗΨΗΣ: 1. H εντολή ΓΙΑ:

ΔΟΜΗ ΕΠΑΝΑΛΗΨΗΣ: 1. H εντολή ΓΙΑ Σχέδιο μαθήματος

Η ανάγκη της επανάληψης:

Η ανάγκη της επανάληψης Πώς θα εμφανίσουμε ένα μήνυμα x φορές , ( όπου x ακέραιος αριθμός με x >1 ); Πώς θα υπολογίσουμε ένα άθροισμα ή γινόμενο με πολλούς όρους ή παράγοντες, που γνωρίζουμε το πλήθος τους ; Πώς θα «βγάλουμε» το μέσο όρο βαθμολογίας της τάξης από 100 μαθητές;

Η σύνταξη της εντολής ΓΙΑ:

Η σύνταξη της εντολής ΓΙΑ ΓΙΑ αριθμητική μεταβλητή ΑΠΟ τ1 ΜΕΧΡΙ τ2 ΜΕ_ΒΗΜΑ β ε ν τ ο λ έ ς ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΠΑΡΑΔΕΙΓΜΑΤΑ ΓΙΑ κ ΑΠΟ 3 ΜΕΧΡΙ 15 ΜΕ_ΒΗΜΑ 4 ΓΡΑΨΕ κ Τέλος_επανάληψης ΓΙΑ i ΑΠΟ 1 0 ΜΕΧΡΙ 1 ΜΕ_ΒΗΜΑ -3 ΓΡΑΨΕ “ καλημέρα ” Τέλος_επανάληψης Σ  0 ΓΙΑ λ ΑΠΟ 3.5 ΜΕΧΡΙ 15 ΜΕ_ΒΗΜΑ 1.5 Σ  Σ+λ Τέλος_επανάληψης Ποιος (ποια δομή) θα μας βοηθήσει;

Διάγραμμα ροής της εντολής ΓΙΑ:

Διάγραμμα ροής της εντολής ΓΙΑ ΠΑΡΑΔΕΙΓΜΑΤΑ ΓΙΑ κ ΑΠΟ 3 ΜΕΧΡΙ 15 ΜΕ_ΒΗΜΑ 4 ΓΡΑΨΕ κ Τέλος_επανάληψης

Διάγραμμα ροής της εντολής ΓΙΑ:

ΠΑΡΑΔΕΙΓΜΑ ΓΙΑ i ΑΠΟ 1 0 ΜΕΧΡΙ 1 ΜΕ_ΒΗΜΑ -3 ΓΡΑΨΕ “ καλημέρα ” Τέλος_επανάληψης Διάγραμμα ροής της εντολής ΓΙΑ

Διάγραμμα ροής της εντολής ΓΙΑ:

Διάγραμμα ροής της εντολής ΓΙΑ ΠΑΡΑΔΕΙΓΜΑ Σ  0 ΓΙΑ λ ΑΠΟ 3.5 ΜΕΧΡΙ 15 ΜΕ_ΒΗΜΑ 1.5 Σ  Σ+λ Τέλος_επανάληψης

Περιορισμοί :

Περιορισμοί Αν βήμα > 0, τότε πρέπει ………………………… Αν βήμα < 0, τότε πρέπει ………………………… Αν βήμα = 1 τότε δεν απαιτείται η αναγραφή του Αν βήμα = 0 τότε ………………………………….. Αν τ1 = τ2 τότε ……………………………………. τ1 <= τ2 τ1 >= τ2 βρόχος ατέρμων (χωρίς περατότητα) ο βρόχος εκτελείται 1 μόνο φορά

Πλήθος επαναλήψεων:

Πλήθος επαναλήψεων [(|τ1 - τ2| / |β|)] + 1, όπου [ Χ ] = ακέραιο μέρος του Χ | Χ | = απόλυτη τιμή του Χ β ≠ 0

Η εντολή Για - Πίνακας τιμών:

Η εντολή Για - Πίνακας τιμών Β  10 Για α από 1μέχρι 4 με_βήμα 2 Β  2*α - Β Γράψε Β Τέλος_επανάληψης Ποια η τιμή του α μετά την επανάληψη; α Β 1 -8 3 14 5

Υπολογισμός αθροίσματος:

Υπολογισμός αθροίσματος S  30 0 Για i από 200 μέχρι 100 με_βήμα -25 S  S + i Τέλος_επανάληψης Γράψε S Ποιο άθροισμα υπολογίζει η επανάληψη;

Υπολογισμός γινομένου:

Υπολογισμός γινομένου P  1 Για i από 2 μέχρι 10 με_βήμα 3 P  P * i ^2 Τέλος_επανάληψης Γράψε P Ποιο γινόμενο υπολογίζει η επανάληψη;

Ρόλος της γραμμής ΓΙΑ… Ρόλος της γραμμής ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ:

Ρόλος της γραμμής ΓΙΑ… Ρόλος της γραμμής ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ Η ΓΡΑΜΜΗ ΓΙΑ Αρχικοποιεί την τιμή του μετρητή Προσδιορίζει την τελική του μετρητή Ορίζει το βήμα μεταβολής Ελέγχει αν η τιμή του μετρητή είναι αποδεκτή ΑΝ είναι αποδεκτή τότε εκτελούνται οι εντολές στο σώμα της ΓΙΑ ΑΛΛΙΩΣ Ο έλεγχος πηγαίνει στην εντολή μετά το ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ Η ΓΡΑΜΜΗ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ Αυξάνει τη τιμή του μετρητή κατά το βήμα Στέλνει τη ροή του προγράμματος στη γραμμή ΓΙΑ

Ασκήσεις με ΓΙΑ:

Ασκήσεις με ΓΙΑ Να γίνει πρόγραμμα, που θα υπολογίζει το άθροισμα S = 1 + 2 + 3 + 4 + … + 300. Ο αλγόριθμος θα πρέπει να εμφανίζει το άθροισμα κάθε φορά που προσθέτει 20 όρους . Να γίνει πρόγραμμα που θα εμφανίζει όλα τα ζεύγη x & y για τα οποία ισχύει 3x – 2y = 5. Οι x και y είναι ακέραιοι στο διάστημα [-30, 30]. Πόσοι είναι οι όροι του αθροίσματος S = 1 + 3 – 9 + 27 – 81 + ….. ώστε το S να μην ξεπεράσει το 4000; Μπορείτε να χρησιμοποιήσετε την εντολή ΓΙΑ για να απαντήσετε στην παραπάνω ερώτηση;

PowerPoint Presentation:

Εμφάνιση 1 ης άσκησης 1

PowerPoint Presentation:

Εμφάνιση 2 ης άσκησης 2

PowerPoint Presentation:

Εμφάνιση 3 ης άσκησης 3 Όχι! Είναι άγνωστο το πλήθος των επαναλήψεων.

authorStream Live Help