DISDIASTATOI PINAKES 3 μπλε

Views:
 
Category: Entertainment
     
 

Presentation Description

No description available.

Comments

Presentation Transcript

Δισδιάστατοι Πίνακες:

Δισδιάστατοι Πίνακες

PowerPoint Presentation:

Φτιάξτε πρόγραμμα που θα διαβάζει τις θερμοκρασίες 30 ημερών του μήνα και θα υπολογίζει τη μέση θερμοκρασία. . . . Σύνολο  0 ΓΙΑ Ημέρα ΑΠΟ 1 ΜΕΧΡΙ 30 ΔΙΑΒΑΣΕ Θερμοκρασία Σύνολο Σύνολο + Θερμοκρασία ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ Μέση Σύνολο/30 . . .

PowerPoint Presentation:

Φτιάξτε πρόγραμμα που θα διαβάζει τις θερμοκρασίες 30 ημερών του μήνα, θα υπολογίζει τη μέση θερμοκρασία και θα υπολογίζει το πλήθος των ημερών που η θερμοκρασία ήταν κατώτερη της μέσης. Α τρόπος Επαναεισαγωγή των θερμοκρασιών για να συγκριθούν με τη μέση Β τρόπος Καταχώρηση κάθε θερμοκρασίας σε διαφορετική μεταβλητή: Θ1, Θ2, Θ3,. . .Θ30 30 ΔΙΑΒΑΣΕ και 30 ΑΝ

Η λύση είναι ο ΠΙΝΑΚΑΣ:

Η λύση είναι ο ΠΙΝΑΚΑΣ Τα δεδομένα καταχωρού-νται κάτω από το ίδιο όνομα μεταβλητής, Θερμοκρασία . T ο στοιχείο Θερμοκρασία[i] αναφέρεται στο i-στό στοιχείο του πίνακα.

ΜΟΝΟΔΙΑΣΤΑΤΟΣ ΠΙΝΑΚΑΣ:

ΜΟΝΟΔΙΑΣΤΑΤΟΣ ΠΙΝΑΚΑΣ

ΜΟΝΟΔΙΑΣΤΑΤΟΣ ΠΙΝΑΚΑΣ:

ΜΟΝΟΔΙΑΣΤΑΤΟΣ ΠΙΝΑΚΑΣ Πίνακας είναι ένα σύνολο αντικειμένων ίδιου τύπου, τα οποία αναφέρονται με ένα κοινό όνομα. Κάθε ένα από τα αντικείμενα που απαρτίζουν τον πίνακα λέγεται στοιχείο του πίνακα. Η αναφορά σε ατομικά στοιχεία του πίνακα γίνεται με το όνομα του πίνακα ακολουθούμενο από ένα δείκτη.

PowerPoint Presentation:

ΠΡΟΓΡΑΜΜΑ Θερμοκρασίες ΜΕΤΑΒΛΗΤΕΣ ΠΡΑΓΜΑΤΙΚΕΣ : Θ[30], Μέση, Σύνολο ΑΚΕΡΑΙΕΣ : i, ημέρες ΑΡΧΗ Σύνολο <- 0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΡΑΨΕ ‘Δώσε τη θερμοκρασία’ ΔΙΑΒΑΣΕ Θ[i] Σύνολο <- Σύνολο + Θ[i] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ Μέση <- Σύνολο/30 ημέρες <- 0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΑΝ Θ[i] < Μέση ΤΟΤΕ ημέρες <- ημέρες+1 ΤΕΛΟΣ_ΑΝ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ ‘Μέση Θερμοκρασία:’, Μέση ΓΡΑΨΕ ‘Ημέρες με μικρότερη θερμοκρασία’, ημέρες ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

PowerPoint Presentation:

ΠΡΟΓΡΑΜΜΑ Θερμοκρασίες ΜΕΤΑΒΛΗΤΕΣ ΠΡΑΓΜΑΤΙΚΕΣ : Θ[30], Μέση, Σύνολο ΑΚΕΡΑΙΕΣ : i, ημέρες ΑΡΧΗ Σύνολο <- 0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΡΑΨΕ ‘Δώσε τη θερμοκρασία’ ΔΙΑΒΑΣΕ Θ[i] Σύνολο <- Σύνολο + Θ[i] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ Μέση <- Σύνολο/30 ημέρες <- 0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΑΝ Θ[i] < Μέση ΤΟΤΕ ημέρες <- ημέρες+1 ΤΕΛΟΣ_ΑΝ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ ‘Μέση Θερμοκρασία:’, Μέση ΓΡΑΨΕ ‘Ημέρες με μικρότερη θερμοκρασία’, ημέρες ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Φτιάξτε πρόγραμμα που θα διαβάζει τις θερμοκρασίες 30 ημερών του μήνα, θα υπολογίζει τη μέση θερμοκρασία και θα υπολογίζει το πλήθος των ημερών που η θερμοκρασία ήταν κατώτερη της μέσης.

PowerPoint Presentation:

Να γραφεί πρόγραμμα που να διαβάζει τις θερμοκρασίες 3 πόλεων για κάθε μια από τις 30 μέρες ενός μήνα. Στη συνέχεια να υπολογίζει τη μέση θερμοκρασία κάθε πόλης. Επίσης, για κάθε πόλη, να υπολογίζει πόσες ημέρες η θερμοκρασία ήταν κατώτερη από την αντίστοιχη μέση. (Τροποποίηση παραδείγματος 3 κεφ. 9 του βιβλίου του μαθητή).

PowerPoint Presentation:

Η προφανής λύση είναι να χρησιμοποιηθούν 3 διαφορετικοί πίνακες για την αποθήκευση των ξεχωριστών θερμοκρασιών για κάθε μια από τις πόλεις.

PowerPoint Presentation:

Θ_Πόλης_1[30] Θ_Πόλης_2[30] Θ_Πόλης_3[30]

Αν όμως αντί για 3 έχω 10 πόλεις. . .:

Αν όμως αντί για 3 έχω 10 πόλεις. . . Να γραφεί πρόγραμμα που να διαβάζει τις θερμοκρασίες 10 (ή 100 ή 1000) πόλεων για κάθε μια από τις 30 μέρες ενός μήνα. Στη συνέχεια να υπολογίζει τη μέση θερμοκρασία κάθε πόλης Επίσης, για κάθε πόλη, να υπολογίζει πόσες ημέρες η θερμοκρασία ήταν κατώτερη από την αντίστοιχη μέση.

PowerPoint Presentation:

θερμοκρασίες για 30 ημέρες 10 διαφορετικές πόλεις συνολικά 300 τιμές θερμοκρασίας δύο δείκτες, ο ένας για την ημέρα και ο δεύτερος για την πόλη Για παράδειγμα η πρώτη πόλη την τριακοστή ημέρα είχε θερμοκρασία 27.

Για παράδειγμα η πρώτη πόλη την τριακοστή ημέρα είχε θερμοκρασία 27.:

θερμοκρασίες για 30 ημέρες 10 διαφορετικές πόλεις συνολικά 300 τιμές θερμοκρασίας δύο δείκτες, ο ένας για την ημέρα και ο δεύτερος για την πόλη Για παράδειγμα η πρώτη πόλη την τριακοστή ημέρα είχε θερμοκρασία 27.

Δηλώσεις πινάκων:

Δηλώσεις πινάκων ΠΡΟΓΡΑΜΜΑ Θερμοκρασίες2 ΜΕΤΑΒΛΗΤΕΣ ΠΡΑΓΜΑΤΙΚΕΣ : Θ[30,10], Μέση[10] ΑΚΕΡΑΙΕΣ : i, j, ημέρες, Σύνολο

PowerPoint Presentation:

Δήλωση πίνακα δύο διαστάσεων . Παραδείγματα: ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ : Π[20,30], i , j , Σ, max , min , ΒΑΘΜΟΣ[10,100] ΠΡΑΓΜΑΤΙΚΕΣ : Κ[10], x , y , ΜΟ, ΜΟ_ΒΑΘΜΩΝ[100] ΧΑΡΑΚΤΗΡΕΣ : ONOMA [100], temp ΛΟΓΙΚΕΣ : ΠΕΡΑΣΕ[10, 100]

Τρισδιάστατος Πίνακας:

Τρισδιάστατος Πίνακας

Πολυδιάστατοι Πίνακες:

Πολυδιάστατοι Πίνακες Εκτός από τους μονοδιάστατους , δισδιάστατους και τρισδιάστατους πίνακες υπάρχουν πίνακες με περισσότερες διαστάσεις τετραδιάστατοι και γενικά πολυδιάστατοι , ανάλογα με τον αριθμό των δεικτών που χρησιμοποιούνται για τον καθορισμό των στοιχείων. Ωστόσο τα περισσότερα προβλήματα αντιμετωπίζονται με τη χρήση πινάκων μονοδιάστατων ή δισδιάστατων.

PowerPoint Presentation:

ΠΡΟΓΡΑΜΜΑ Θερμοκρασίες2 ΜΕΤΑΒΛΗΤΕΣ ΠΡΑΓΜΑΤΙΚΕΣ : Θ[30,10], Μέση[10] ΑΚΕΡΑΙΕΣ : i, j, ημέρες, Σύνολο ΑΡΧΗ ! Εισαγωγή δεδομένων ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 ΓΡΑΨΕ ‘Δώσε τη θερμοκρασία’, i, j ΔΙΑΒΑΣΕ Θ[i,j] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ !Υπολογισμοί ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 Σύνολο <- 0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 Σύνολο <- Σύνολο + Θ[i,j] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ Μέση[j] <- Σύνολο/30 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 ημέρες <- 0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΑΝ Θ[i,j] < Μέση[j] ΤΟΤΕ ημέρες <- ημέρες+1 ΤΕΛΟΣ_ΑΝ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ ‘Μέση Θερμοκρασία ’, i, ‘Πόλης:’, Μέση[j] ΓΡΑΨΕ ‘Ημέρες με μικρότερη θερμοκρασία’, ημέρες ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

PowerPoint Presentation:

ΠΡΟΓΡΑΜΜΑ Θερμοκρασίες2 ΜΕΤΑΒΛΗΤΕΣ ΠΡΑΓΜΑΤΙΚΕΣ : Θ[30,10], Μέση[10] ΑΚΕΡΑΙΕΣ : i, j, ημέρες, Σύνολο ΑΡΧΗ ! Εισαγωγή δεδομένων ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 ΓΡΑΨΕ ‘Δώσε τη θερμοκρασία’, i, j ΔΙΑΒΑΣΕ Θ[i,j] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ !Υπολογισμοί ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 Σύνολο <- 0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 Σύνολο <- Σύνολο + Θ[i,j] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ Μέση[j] <- Σύνολο/30 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

PowerPoint Presentation:

ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 ημέρες <- 0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 ΑΝ Θ[i,j] < Μέση[j] ΤΟΤΕ ημέρες <- ημέρες+1 ΤΕΛΟΣ_ΑΝ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ ‘Μέση Θερμοκρασία ’, i, ‘Πόλης:’, Μέση[j] ΓΡΑΨΕ ‘Ημέρες με μικρότερη θερμοκρασία’, ημέρες ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

«Γέμισμα» πίνακα δύο διαστάσεων:

«Γέμισμα» πίνακα δύο διαστάσεων Πίνακας ΒΑΘΜΟΣ[10,100] που στη μία διάσταση (των γραμμών) αντιστοιχούν τα 10 μαθήματα, ενώ στη δεύτερη (των στηλών) οι 100 μαθητές. Κάθε στοιχείο ΒΑΘΜΟΣ[ i , j ] περιέχει τη βαθμολογία που πήρε ο j μαθητής στο i μάθημα.

PowerPoint Presentation:

!εντελώς απλοϊκός τρόπος ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 100 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10 ΔΙΑΒΑΣΕ ΒΑΘΜΟΣ [ i , j ] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

PowerPoint Presentation:

! πιο λεπτομερής και σωστός τρόπος ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 100 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10 ΓΡΑΨΕ ‘Δώσε το βαθμό που έγραψε ο μαθητής ‘, j , ‘στο μάθημα’, i ΔΙΑΒΑΣΕ ΒΑΘΜΟΣ [ i , j ] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

PowerPoint Presentation:

!Με έλεγχο εγκυρότητας ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 100 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10 ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ ‘Δώσε το βαθμό που έγραψε ο μαθητής ‘, j , ‘στο μάθημα’, i ΔΙΑΒΑΣΕ ΒΑΘΜΟΣ [ i , j ] ΜΕΧΡΙΣ_ΟΤΟΥ ΒΑΘΜΟΣ [ i , j ] >=0 ΚΑΙ ΒΑΘΜΟΣ [ i , j ] <=20 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

PowerPoint Presentation:

Με τους παραπάνω τρόπους το διάβασμα του πίνακα ΒΑΘΜΟΣ[10,100] γίνεται κατά μαθητή. Δηλαδή για το μαθητή 1 πρώτα ζητούνται όλοι οι βαθμοί που πήρε στα 10 μαθήματα, μετά συνεχίζει το διάβασμα των βαθμών για τον 2ο μαθητή, κλπ. Αυτό γίνεται γιατί η επανάληψη με το j (από 1 έως 100) γίνεται ΕΞΩΤΕΡΙΚΑ και η επανάληψη με το i (των γραμμών από 1 έως 10) γίνεται ΕΣΩΤΕΡΙΚΑ.

Εναλλακτικά, θα μπορούσε να γίνει με τον εξής τρόπο::

Εναλλακτικά, θα μπορούσε να γίνει με τον εξής τρόπο: ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 100 ! η επανάληψη του j είναι εσωτερική τώρα ΓΡΑΨΕ ‘Δώσε το βαθμό που έγραψε ο μαθητής ‘, j , ‘στο μάθημα’, i ΔΙΑΒΑΣΕ ΒΑΘΜΟΣ [ i , j ] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

PowerPoint Presentation:

Κατά το «γέμισμα» ενός πίνακα δύο διαστάσεων θα μπορούσαμε να «γεμίσουμε» και άλλους πίνακες που εμπλέκονται στο πρόβλημα (ή χρησιμοποιούνται στο πρόγραμμα). Όπως για παράδειγμα το «γέμισμα» του πίνακα με τα ονόματα των μαθητών: ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 100 ΓΡΑΨΕ ‘Δώσε το όνομα του ‘, j , ‘μαθητή’ ΔΙΑΒΑΣΕ ΟΝΟΜΑ[ j ] !πρώτα διαβάζουμε το όνομα του μαθητή ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10 !και γι’ αυτόν όλους τους βαθμούς του ΓΡΑΨΕ ‘Δώσε το βαθμό που έγραψε ο μαθητής ‘, ONOMA [ j ] , ‘στο μάθημα’, i ΔΙΑΒΑΣΕ ΒΑΘΜΟΣ [ i , j ] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

«Εμφάνιση» πίνακα δύο διαστάσεων:

«Εμφάνιση» πίνακα δύο διαστάσεων Στον προηγούμενο Πίνακα ΒΑΘΜΟΣ[10,100] που στη μία διάσταση (των γραμμών) αντιστοιχούν τα 10 μαθήματα, ενώ στη δεύτερη (των στηλών) οι 100 μαθητές. Κάθε στοιχείο ΒΑΘΜΟΣ[ i , j ] περιέχει τη βαθμολογία που πήρε ο j μαθητής στο i μάθημα. ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 100 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10 ΓΡΑΨΕ ΒΑΘΜΟΣ [ i , j ] !εντελώς απλοϊκός τρόπος ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

PowerPoint Presentation:

! πιο λεπτομερής και σωστός τρόπος ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 100 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10 ΓΡΑΨΕ ‘Ο βαθμός που έγραψε ο μαθητής ‘, j , ‘στο μάθημα’, i ,’είναι’, ΒΑΘΜΟΣ [ i , j ] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Εναλλακτικά, θα μπορούσε να γίνει με τον εξής τρόπο::

Εναλλακτικά, θα μπορούσε να γίνει με τον εξής τρόπο: ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 100 ! η επανάληψη του j είναι εσωτερική τώρα ΓΡΑΨΕ ‘Ο βαθμός που έγραψε ο μαθητής ‘, j , ‘στο μάθημα’, i ,’είναι’, ΒΑΘΜΟΣ [ i , j ] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΑΘΡΟΙΣΜΑΤΑ:

ΑΘΡΟΙΣΜΑΤΑ

PowerPoint Presentation:

!Άθροισμα γραμμής Άθροισμα _γραμμής  0 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ M Άθροισμα _ γραμμής  Άθροισμα _ γραμμής + Πιν [3, j ] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ !Και αντίστοιχα για τη στήλη Άθροισμα _στήλης  0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ N Άθροισμα _στήλης  Άθροισμα _ στήλης + Πιν [ i ,5] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Το συνολικό άθροισμα όλων των στοιχείων του πίνακα μπορεί να γίνει ως εξής::

Το συνολικό άθροισμα όλων των στοιχείων του πίνακα μπορεί να γίνει ως εξής: Άθροισμα _ολικό  0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ N ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ M Άθροισμα _ολικό  Άθροισμα _ολικό + Πιν [ i , j ] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

PowerPoint Presentation:

Αν θέλουμε να δημιουργήσουμε ένα μονοδιάστατο πίνακα με το άθροισμα κάθε γραμμής, απλά μετασχηματίζουμε ελαφρά το προηγούμενο κομμάτι αλγορίθμου περικλείοντάς το μέσα σε εξωτερική επανάληψη για τη γραμμή ή τη στήλη, ανάλογα.

Π.χ. τα προηγούμενα γίνονται::

Π.χ. τα προηγούμενα γίνονται: ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ N Άθροισμα _γραμμής  0 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ M Άθροισμα _ γραμμής  Άθροισμα _ γραμμής + Πιν [ i , j ] ! αντί για Πιν [3, j ] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΠΙΝΑΚΑΣ_ΓΡΑΜΜΗΣ[ i ]  Άθροισμα _ γραμμής ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Και αντίστοιχα για τη στήλη:

Και αντίστοιχα για τη στήλη ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ M Άθροισμα _στήλης  0 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ N Άθροισμα _στήλης  Άθροισμα _ στήλης + Πιν [ i , j ] ! αντί για Πιν [ i ,5] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΠΙΝΑΚΑΣ_ΣΤΗΛΗΣ[ j ]  Άθροισμα _ στήλης ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΑΘΡΟΙΣΜΑΤΑ:

ΑΘΡΟΙΣΜΑΤΑ

authorStream Live Help